Comment # 13 on bug 4532 from
Sorry for the delay, here is a first review.

1) Package version is not 17.1. You should refer to the
inputstream.adaptive/ file to get the right version corresponding
to the snapshot you're packaging. The snapshot you're packaging corresponds to
a 1.0.6 version (see
You should ask upstream to create release tags to make things easier for you...
Even if it quite rare from Kodi addon developers :(.

2) As a result, you should set up a dedicated for the minimum required Kodi
version. By the way, since Kodi addon API is stable between major release,
requiring kodi >= 17.0 may be enough:

%global kodi_version 17.0


BuildRequires:  cmake
BuildRequires:  gcc-c++
BuildRequires:  kodi-devel >= %{kodi_version}
BuildRequires:  kodi-platform-devel >= %{kodi_version}
BuildRequires:  expat-devel

Requires:       kodi >= %{kodi_version}

3) If you plan to package more binary Kodi addons and use this .spec as a
model, I suggest you to define your package name from the upstream name, and
not the reverse (in case some Kodi addons may use dashes as separators).
Replace :

Name:           kodi-inputstream-adaptive
%global aname %(n=%{name}; n=${n//-/.}; echo ${n:5})


%global aname inputstream.adaptive
Name:           kodi-%(n=%{name}; n=${n//./-})

4) Binary addons are dlopened at Kodi execution. They're not shared libraries.
As a result, you don't need to call ldconfig at post-install. Remove
%post/%postun targets.

5) This addon bundled libbento4. If you don't plan to unbundle this third-party
library as allowed by Fedora guidelines, you must add a virtual Provided on
this library:

Provides: bundled(bento4)

(unfortunately I'm unable to determine which version of bento4 is bundled).

You are receiving this mail because: