I don't think you need the updates - testing repo anymore. I just installed the 340xx driver the other day, on a box with a GeForce 8600, and it worked fine. 

-------- Original message --------
From: Roderick Johnstone <rmj@ast.cam.ac.uk>
Date:03/02/2015 6:12 AM (GMT-05:00)
To: rpmfusion-users@lists.rpmfusion.org
Subject: Re: nvidia kernel modules and drivers for F20


Thanks for your suggestions.

I was able to resolve this with:

For systems with older grahics cards:
yum erase xorg-x11-drv-nvidia
yum --enablerepo=rpmfusion-nonfree-updates-testing install
akmods --kernel 3.18.7-100.fc20.x86_64

For systems with newer graphics cards:
yum erase xorg-x11-drv-nvidia-340xx
akmods --kernel 3.18.7-100.fc20.x86_64

I just run the akmods commands by hand to be sure that the kmod will be
built ok before rebooting.


On 25/02/15 20:00, Nicolas ViƩville wrote:
>> I ran into this a couple of weeks ago. I think that something was broken
>> in the repos for a short period.
> Also I ;)
> In order to avoid the uninstall of a lot of packages due to
> dependencies, and to proceed on 20 machines, I preferred to use a less
> elegant way (use it at your own risk - be careful some one line commands
> are split on multiple lines in this message and you may have to adapt
> the name of the packages to yours):
> rpm -e --nodeps xorg-x11-drv-nvidia-340xx.x86_64 \
> xorg-x11-drv-nvidia-340xx-libs.i686 \
> xorg-x11-drv-nvidia-340xx-libs.x86_64
> yum -y install xorg-x11-drv-nvidia-libs.i686 \
> xorg-x11-drv-nvidia-libs.x86_64 xorg-x11-drv-nvidia.x86_64
> akmods --force
> rpm -e kmod-nvidia-340xx-3.17.8-200.fc20.x86_64-340.65-3.fc20.1.x86_64
> akmods --kernel 3.17.8-200.fc20.x86_64
> then to be sure:
> yum -y upgrade
> and
> reboot
> Hope this will help.
> Cordially,